Support GeoPad Professional Fält

 

FAQ Geo

Få svar på dina Geo-frågor

Nedan hittar du svar på vanliga frågor som ställs om Geo Professional

Geo FAQ

Maskinstyrningsfiler för Topcon

När det gäller terrängmodeller till Topcon maskinstyrning så har GEO stöd för formatet som kallas TN3. Under Arkiv > Import/Export… > Topcon. Där kan man exportera sin TRM-fil till en TN3-fil som sedan läses in i maskindatorn. TN3-filen skall sparas direkt i rooten på USB-minnet.

Med Väglinje (*.lin) + Profil (*.prf) + Sektion (*.sec) som skapas i Geo Professional, finns möjlighet att med hjälp av Topcon´s program 3D-Office exportera väglinjer till maskindatorn.

För bakgrundskartor är det enklast att spara filen som Autocad DWG. Dessa får ej vara nyare än Autocad version 2010. Dessa kan läsa in i Topconprogrammet 3D-office. Programmet hittar man i Norsecraft filarkiv

Det finns även en snabbguide som beskriver hur man exporterar data skapad i Geo Professional med 3D-office. Snabbguide för export/import i 3D-Office

Maskinstyrningsfiler för Trimble

När det gäller data till Trimbles maskinstyrning så har Geo Professional inget för deras fil-format.

Vi måste förbereda våra data i GEO som vanligt och som sedan exporteras i formatet Landxml. Under Arkiv > Import/Export… kan man exportera Terrängmodeller (*.trm) och/eller Väglinje (*.l3d) till Landxml.

Landxml:en kan då hanteras i Trimbles egna program, Fileflipper eller Business Center.

Arbetsflöde för att exportera till Trimbles dataformat finns att hitta på länken Exportera till Trimble

Maskinstyrningsfiler för MOBA

När det gäller X-site pro så kan man skapa alla sin data i Geo Professional, som sedan exporteras till maskinen.

Terrängmodeller (*.trm) och Koordinatfiler (*.geo) kan exporteras direkt till systemet.

Väglinje (*.l3d) kan exporteras på 2 olika sätt

  • Sparas om till formatet *.lin+*.prf, tänk på att båda dessa filer måste ha samma namn.
  • Exporteras till Landxml for Visual machine.

Linjemodell (*.lmd) exporteras till Landxml for Visual machine.

Autocad DWG-filer (*.dwg) får man spara om till Autocad DXF (*.dxf) Använd Arkiv > Spara som…

Filerna som ska till maskinen sparas i en katalog på rooten på USB stickan eller kopieras i ftp:en.

Länken Exportera till MOBA beskriver utförligare hur man utför exporteringen från Geo Professinal till X-site pro.

Prenumeration

Vid köp av en licens på Geo följer ett års prenumeration. Under detta året har ni support på programmet samt möjlighet att installera de versioner vi släpper, även om det sker en namnbyte på grund av årskifte. Om prenumerationen löpt ut eller är på väg att löpa ut kan en förlängning beställas via den här länken: Uppdatera Geo prenumerationsavtal.

Programmet kommer heller inte sluta fungera efter att prenumerationen löpt ut, det är endast möjligheten att installera nya versioner samt rätten till support som påverkas.

Om licensen är knuten till ett hårdvarulås behöver informationen på det förnyas också. Information om hur det går till hittas här: Dongle Tool

Licenshantering

För att köra Geo Professional krävs en licens. Det finns två typer av licens: den som går mot ett hårdvarulås och den som ansluter mot vår licensserver.

Lösningen med hårdvarulås är för en samtidig användare och låset måste sitta på den datorn som ska köra Geo.

Nätverkslicens kräver Internet-anslutning under hela körningen med Geo. Programmet installeras dock lokalt. Denna lösning möjliggör att flera användare samtidigt kan köra programmet och antalet användare bestäms av hur många som samtidigt behöver kunna använda det.

Med nätverkslicens är det också möjligt att koppla till ett eller flera hårdvarulås och som då används för att checka ut moduler från modulpoolen under en begränsad tid. Är det problem med möjligheten att koppla upp sig är detta en smidig lösning. Kontakta vår support eller orderavdelning om ni vill ha mer information om det.

Installation

– Första gången på en ny dator

Ladda ner en komplett installationsfil här . När nerladdningen är klar, dubbelklicka på filen. Observera att det vanligtvis krävs administratörsrättigheter. Det öppnas nu en meny där det finns val för olika installationer.

Geo Installationsmeny

Välj ”Install Geo” och följ anvisningarna i dialogen. I dagsläget är det ingen skillnad mellan ”Typical” och ”Complete”. Görs inga ändringar installeras Geo under C:\program(x86)\GeoXXXX där XXXX står för årtalet i Geoversionen, 2014/15/16.

– Uppdatering

Om Geo ska uppdateras med en ny version räcker det med att ladda ner installationsfilen för programmet endast. På nerladdningssidan finns två val, komplett och endast msi. I det här fallet är det msi-fil som är aktuellt. Den väsentliga skillnaden mellan dessa filer är att msi-filen endast innehåller Geo och det dyker inte upp en meny enligt ovan. Följ instruktionerna under installationsprocessen.

– Drivrutiner till hårdvarulås

För Windows XP/Vista/7/8.x

Drivrutiner finns att installera antingen via en komplett installationsfil för Geo, se ovan, eller genom att ladda ner drivrutinerna här. OBS! Hårdvarulåset ska inte sitta i datorn under installationen.

För Windows 10

Windows 10 hittar drivrutinerna själv när låset stoppas i. Om det mot förmodan inte skulle fungera, gå in under Enhetshanteraren och välj att uppdatera drivrutinerna där. Se bild

Enhetshanteraren

– Punktmoln

Punktmolnsmodulen installeras inte automatiskt med Geo och det beror på att det finns två olika versioner. En för 32-bit och en för 64-bit Windows. För att installera punktmolnsmodulen, ladda ner en komplett installationsfil för Geo och välj den version som matchar ditt operativsystem. ”Install Point Cloud Utility (32/64 bit).

Punktmoln

– Kan jag ha flera olika versioner av Geo installerat samtidigt?

Ja, det är fullt möjligt. Se bara till att programmets sökväg inte blir densamma som vid den första installationen. Det är däremot inte möjligt att installera en äldre version över en nyare. Då måste den nyare först avinstalleras.

– Avinstallation

Geo avinstalleras enklast via Kontrollpanelen under ”Lägg till/ta bort program” alternativt ”Program och funktioner”. Om en ny version ska installeras är det viktigt att avinstallera den gamla först om den inte ska vara kvar (gäller mellan årsmodeller, 2014, 2015 osv) eftersom det finns gemensamma filer mellan versionerna. Om t.ex. Geo 2016 installeras på en dator som redan har Geo 2015 och denna version sedan avinstalleras kommer inte Geo 2016 fungera fullt ut eller inte alls.

Geo startar inte efter installation.

– Allmänt

  • Först ska man kolla att Windows är uppdaterat. Klicka på windowsflagga och kugghjulet, välj ”Uppdateringar och säkerhet”. Installera dessa och starta om datorn.
  • Ett meddelande om att dll-fil saknas (t.ex. GComm.dll): Avinstallera Geo och installera om Geo med administratörsrättigheter, säkrast är att högerklicka på körbar fil och välja ”Kör som administratör”
  • Om man får meddelande om att sida vid sida-konfigurationen, kan det saknas något i de vanliga programmiljöpaketen. Dessa måste installeras genom att högerklicka och välja ”Kör som administratör
  • Länk till 2008
  • Länk till 2015, 2017, 2019

– Hårdvarulås som USB

  • ”No matching feature found (H00050)”: Detta betyder att man har ett gammalt lås som inte fungerar till 64bit Geo, 32bit fungerar dock. Vill man kunna köra 64bit, måste man ha ett nyare hårdvarulås och uppdaterade drivrutiner. För mer info om 64-bitars Geo, klicka här
  • Felkod:7 Betyder att fel licenskod är inmatad eller att Geo inte hittar hårdvarulåset. Sitter låset bakom en brandvägg måste portarna 3047/udp och 3047/tcp öppnas upp. Det kan också bero på gamla drivrutiner.
  • Felkod:14 Betyder att drivrutinerna inte är korrekt installerade. Färska drivrutiner går att ladda hem från vår hemsida. Klicka här!

Det krävs administratörsrättigheter av användaren som ska installera dem och se till att hårdvarulåset inte sitter i datorn vid installationen.

– Licensserver via internetuppkoppling

-Det uppstod ett fel i kommunikationen med licensservern. Felkod:X

  • 400: Identifieringskoden kan vara fel. Bindestrecken i koden har inte angivits. Koden kan ha gått ut.
  • 407: HTTP Error Proxy authentication required. Kolla att adresserna https://licenseeu.sbg.se or https://license.sbg.se fungerar genom att ange dem i en webläsare. Man kan också få felet om man har ett oregistrerat lås i datorn.
  • 504: Kolla om server är nere eller om någon av adresserna https://licenseeu.sbg.se eller https://license.sbg.se stoppas i brandväggen.

– Byte av licenskod

Radera filen certificate.xml. Filen hittar du om du kopiera in %LOCALAPPDATA%\sbg\geo i ”Utforskarens” adressfält

-Misslyckades att ansluta mot licensservern. Kontrollera att nätverksanslutningen fungerar korrekt.
-Ett nätverksfel inträffade vid anslutning mot licensservern. Kontrollera att nätverksanslutningen fungerar korrekt.

  • Geo lyckas inte koppla mot licensservern. Kontrollera att nätverksanslutningen är ok. Om det finns en brandvägg, kontrollera att den släpper igenom nödvändig trafik för Geo.
  • Felet kan även vara relaterat till certifikatet. Om nätverket fungerar som det ska, prova att radera certificate.xml %LOCALAPPDATA%\sbg\geo, starta Geo på nytt och mata sedan in koden igen.
  • Kolla även att tiden och datumet på datorn är korrekt.
Arbeta mot projekt på företagsserver i Geo Professional.

– Om funktioner har problem att hitta kataloger eller filer

  • Tänk på att den totala sökvägen är begränsad till 256 tecken i windows. Man kan läsa mer om detta här
  • Man måste ofta ”Mappa” den katalogen man är tilldelad till på servern. Detta betyder att katalogen får en egen enhetsbokstav på din dator. Detta kan se ut ungefär så här: Z:\folder\projects. I Win10 så hittar man funktionen under Start > Enkel åtkomst.
  • Är det en synk-katalog som Dropbox och Onedrive använder, är detta inte nödvändigt då det redan ligger en katalog på datorn.
Handdator får inte kontakt med PC

Microsoft har inför strängare krav för anslutningar mot PC i Win10 och man måste lägga till några förändringar som fixar detta. Koppla bort din handdator. Se till att du installerat ”Windows Mobile Device Center”, du hittar den under vår ”Nedladdning Geo” –> PC-Handdator Kommunikation

Öppna kommandotolken som administratör (Tryck på flagga –> Skriv ”cmd” –> Högerklicka –> Välj ”Kör som administratör”

Skriv in, följande 2 kommandon, ett i taget, och tryck ”Enter”

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

Skriv in följande om du har Win10 på SVENSKA och tryck ”Enter”

net localgroup Administratörer LocalService /add

Skriv in följande om du har Win10 på ENGELSKA och tryck ”Enter”

net localgroup Administrators LocalService /add

Starta om datorn

Efter omstart och handdatorn är ansluten, brukar WMDC starta installation och ansluta… annars se nedan

Klicka på windows flagga och sök efter ”Mobile” –> Klicka på ”Windows mobile device center” eller liknande

Klicka på vänstra ”Acceptera”

Nu ska programmet starta –> Anslut din handdator och se om den ansluter

Import/Export Instrument

Geoidmodellsfiler för Leica, Topcon och Trimble som Lantmäteriet har nedladdning för hittar du här: Länk

– Leica

  • Geo frågar efter en geoid-fil som heter nnnn.gem och man får inga höjder.
    • Detta är en fil som troligtvis finns på ditt cf-kort med Leica trädstruktur. Leta under kort\data\gps\geoid. Gå in i inställningar för Imp/Exp leica dbx/gsi. Längst ner i inställningar får man ange sökvägen till geoid-filen.
  • Meddelandet ”Conversion failed” visas eller ”Detta är inte ett punktjobb, och därför inte möjligt att importera via printFPC”
    • Man är ansluten med kabel och kör fortfarande job man vill hämta data ur.
    • Man har glömt avsluta job på instrument, så data är inte sparat korrekt.-
    • DBX-katalogen innehåller korrupt data, som antagligen behövs tas bort.
  • Meddelandet ”File generation failed” visas.
    • Sökvägen till dbx-katalogen är inte korrekt i inställningar
  • Meddelande om att dll-fil saknas eller att databas är korrupt.
    • Installera om paketet ”Visual C++ Redistributable for Visual Studio 2015” Klicka här
  • Meddelandet ”File doesn’t exist. Try reloading the window”
    • Dbx-filens namn innehåller flera punkter i filnamnet, byt ut mot understreck eller ta bort punkter. Eventuellt måste alla tillhörande filer byta till samma namn(eg. Xnn-filer)
  • Meddelande ”Sida vid sida konfigurationen”
    • Installera ”Visual C++ redistributable 2008”
  • För att kolla om det är något strul med tillägg-programmen som krävs vid dbx-överföringen
    • Gå till följande adress på din dator ”Installera ”C:\Program Files (x86)\Leica Geosystems\DBX Tools\”. Här ligger både PrintFPC och RoadRunner, som man kan dubbelklicka på och kolla att de startar

– Trimble

  • Kan inte installera Trimble DiNi digital level för att konvertera en DAT-fil
    • Detta är en gammal funktion då man var beroende av kabel och en COM-port på datorn, och eftersom det inte finns COM-portar längre på nyare datorer så blir det lite bekymmer att installera då detta krävs. Det finns dock en omväg för att installera och det är inte säkert man har rättigheter att göra detta själv
    • Öppna registereditorn: Windowsflagga > Skriv ”regedit”
    • Leta upp katalogen: HKEY_CURRENT_USER\Software\Svensk Byggnadsgeodesi\Geo\Communication
    • Högerklicka > ”Strängvärde” > ”Trimble DiNi digital level” > Värde: 7 0 5 7 0 3 0 1
    • Det är viktigt med mellanslagen
    • Starta om Geo och gå till kommunikation, nu ska det finnas en ”Trimble DiNi digital level” i listan och det ska vara möjligt att konvertera en dat-fil
  • Trimble terrängmodeller (ttm) går inte att överföra via TrimbleDC
    • Använd Trimble Link så länge, man kan behöva uppdatera Trimble link via vår Geo Nedladdningssida. I värsta fall kan man kopiera en fil i 32-bitars versionen
  • Problem med att hitta geoid och höjddata blir fel.
    • När man för över trimbledata, och en geoid-modell har använts i trimbles system måste man ha samma modell i vårt system, och vårt format, och den måste heta precis samma sak. Problemet är att trimble inte hanterar de långa namnen, så man måste korta ner detta. Lättast är att ta en kopia på våran fil i global-katalogen och sedan byta namn.
Geoidmodell Geo namn Trimble namn vid överföring Trimble namn i deras program
Sweden 2008 RH 1970 Swen08_RH70.grd SW08RH70.grd SW08RH70.ggf
Sweden 2008 RH 2000 Swen08_RH2000.grd SW082000.grd SW082000.ggf
Sweden 2005 RH 1970 Swen05_RH70.grd SWEN0570.grd SWEN0570.ggf
  • Problem med GNSS, höjder och restfelsmodeller
    • GNSS-filer som använder resfelsmodeller importeras inte korrekt om man använder formaten DC 10.7 eller SC Exchange. Använd formatet SDR33 vid importen, samt att se till att restfels(deformations)modellen och ev. geoid även ligger i mappen ..Program\Delade filer\Trimble\Geodata. Format på restfelsmodellen är *.SGF.
  • Importen frågar efter fil i katalogen ”Geodata”.
    • Detta är en katalog som används av Trimble. Om man inte har denna, måste man installera ”Configuration Toolbox” som tillhandahålls av Trimble. Här läggs geoidmodeller(*.ggf) och restfelsmodeller(*.sgf)
  • Följande felmeddelande visas.
    ErrorImpTrimble

    • Troligen har du något antivirusprogram eller nån brandvägg som har ändrat i registereditorn, det är därför det här problemet uppstår. I registereditorn, expandera HKEY_CLASSES_ROOT. Scrolla till Trimble.RemoteDeviceManager.XMSurveyController. Högerklicka på den och ändra till full behörighet (Obs! gör detta för samtliga användare!). Starta sedan om datorn så bör det fungera.
  • ”Could not open open the file” när man använder Trimble link.
    • Kolla att filnamnet inte innehåller flera punkter och andra specialtecken som åäö.
Export till Trimble format slutade fungera

Detta kan bero på att man använder Geo med 64-bitars version. ”Trimble link” och ”Trimble DC” har ingen version av sitt program i 64-bitars version.

Man måste då avinstallera 64-bitars versionen av Geo och installera 32-bitars först och 64-bitars efter det. När man sedan behöver använda ”Trimble Link”, så måste man köra 32-bitars versionen av Geo.

2018-08-25 Vi håller på att kolla om detta går att komma runt

2019-01-19 Om man installera senaste version av Trimble Link så verkar det fungera

Man kan även behöva lägga till en ny enhet och det ska vara ”Trimble Access (Windows Mobile)”

Autocad DWG/DXF

– Varför ser jag inte ritningsramen i AutoCad när den finns med i Geo?

I AutoCad finns det två olika arbetsytor, en som heter modell, model space, och ritningsramen finns i det som kallas Layout, paper space. Precis som i Geo finns det två eller fler flikar där det går att växla mellan dessa olika världar. Under Data-menyn finns valet Välj Aktiv Layout och välj någon av layouterna som finns där.

– Det går att ta emot AutoCad-filer men kan jag även leverera i t.ex. dwg-format?

Ja, det är fullt möjligt. När det grafiskt är färdigt för export, gå in under Vyer/Spara vy som och välj AutoCad-fil. Där finns möjligheten att, inte bara göra en dwg-fil, utan även välja vad som ska hamna i vilka lager i ritningen.

– När jag öppna min AutoCad-fil(dwg) i AutoCad så syns inte mina punkter.

Detta kan bero på att AutoCad inte vet hur den ska rita punkter och då använder den en standardinställning för detta som normalt är 1 pixel. Detta kan man ändra genom att i AutoCad skriva in commandot ”ptype” och sedan välja med vilken symbol man ska rita ut punkter.
Ett annat alternativ är att sätta en punktkod ifrån vår kodlista ”sbg2.cod” och sedan använda de AutoCad-mallar som vi skickar med, när man använder ”Spara vy som AutoCad…”

– Jag kan inte öppna eller inte se nått i min dwg-fil

Detta kan bero på att dwg innehåller något som heter ”proxy graphic objects”. Detta betyder att ett 3:e parts program/plugin har skapat ett grafiskt objekt som inte vanliga Autocad läser utan man behöver ha ett tillägg sk. ”Objekt Enabler” för att det ska gå att visa. Geo har ingen hantering för detta utan man måste då i autocad (finns för true view också) hämta ”object enabler” och explodera dessa objekt, sedan spara/exportera till Autocad DWG-format. Program som använder detta är t.ex Autocad Civil 3D, MagicCAD (VA, Vent, El). Länk till autodesk för att få information hur man gör export från Civil3D till standard autocad, klicka här

Det kan fungera att explodera AEC objekten, se bild nedan. Funktionen i Autocad heter DWG Convert (DWGCONVERT)

Det kan också vara Externa referenser man inte har fått men som länkas till. Dessa listas i in- och utmatningsrutan som röd text, alternativt syns de i listan Data > Externa referenser… Dessa får man fråga efter och bäst spara tillsammans med den dwg man öppnar. Ett bra alternativ är att be den som skapat dwg att använda funktionen eTransmit i Autocad, då sparas allt som ett arkiv(ZIP) och allt hänger med.

Data kan vara utspritt om den som gjort filen glömt att rensa. Då kan data t.ex. ligga runt nollan(0) samt även på korrekt ställe X=6000000,Y=150000. Då är det svårt att se datat och det visas bara som 2 pixlar i grafiken. Prova zooma på rätt ställe och även markera och ta bort data, på ställen där man inte har data. Rensa flera gånger med Data > Purge (Rensa) till du ser ett ”N” i in- och utmatningsfönstret. Därefter ska man använda Data > Audit (Granska)

Data kan vara i mm och då har vi en funktion Data > Tranformera… >> mm > m

– Linjetyper syns inte i min dwg

Linjerna i dwg är i 3D och då hanteras inte linjetyper. För att fixa detta så måste linjerna läggas i samma höjd(2D) eller göras om i Civil3D till ”Feature Line”, se mer info genom att klicka här

– Jag får en singelpunkt på samma ställe som noderna på polylinjerna när jag gör dwg

Stäng av inställningen att visa punkter på linjer. Ibland så vill man ha med textinformation vid noderna och då är detta insättningspunkten.

– Geo kan inte extrahera ytor från en AcDbPolyFaceMesh

Explodera mesh så blir det AcDbFace och det kan vi konvertera till terrängmodell (trm)

Om attribut till punkter

De senaste attributfilerna hittar du här: Länk till zip. Packa upp till globalkatalogen.

Förklaringar till många av dessa hittar ni på vår sida ”Ladda ner > GeoPad”. En genväg till dokumentet hittar du här: Länk

Attribut är information som man knyter till punkters position. Detta kan kallas lite annat i andra program, som metadata o.s.v. Syftet är att man kan ha mycket information som är relaterat till en inmätning och man kan behöva knyta detta till punkten. Eg. är allt som knyts till en position, attribut, t.ex är Punktnamnet ett ID på punkten för att lättare kunna hitta den i en lista och punktkod, en beskrivning ifrån en kodlista. Det finns också annan information som kan knytas till punkten. Det kan vara automatisk information, som man kan få från sitt instrument, men det kan även vara egenskapad information som man vill lägga till. I vår attributlista som vi skickar med, som man kan mäta med i vår programvara GeoPad finns det ett antal attribut som kan vara lämpliga att använda när man mäter.

– För att lagra attribut i GeoPad

Välj attributfil i geopad under inställningar (kugghjulet) > Kodlista och attribut. Mest komplett fil är: ”standard_BH90.atr”. I lagringsinställningar vid Mätning så bockar man för ”Spara utökad data”

– För att visa attribut i Geo

Välj attributfil i projektet under Redigera > Inställningar > Attribut. Välj samma som du använde i fält. Mer om attribut hittar du i geo-hjälptexten. Sök efter ”attribut”.

-Få med sig attributen vid en Autocad export

Se till att välja en attributfil under Redigera > Inställningar > Flik Attribut. Tänd upp attributen som text i koordinatfilen egenskaper.

-Få med sig attributen vid export till ESRI Shape

Vid export, välj mallen geo2shape.xml. Det är bara punktattribut som fungerar just nu

Volymberäkning Modell mot modell

– Modell-mot-modell fungerar inte – punkter markeras i hjälplagret.

Ibland klarar inte Geo att beräkna modell mot modell och anledningen till det varierar. Genom att öppna terrängmodellerna och tända hjälplagret kan punkterna som markerats ge en fingervisning om vad som gått snett. Det finns några grepp man kan ta till för att komma runt problemen.

  • Prova att rotera trianglar i området/områdena där punkterna har skapats.
  • Fungerar inte det kan det hjälpa att flytta en av modellerna litet, ett par millimeter i X eller Y kan göra stor skillnad.
  • Om många smala trianglar ansluter mot en nod kan det skapa problem, försök då att lägga in fler punkter i geo-filernas brytliner.

– Hur kan jag få fram en linje som beskriver skärningen mellan två terrängmodeller?

Beräkna Modell mot modell och skapa en resultatfil, differensmodell. Med denna fil aktiv:

  • Skapa nivåkurvor vilka får färg efter om de tillhör schakt- eller fyllområden. Det skapas även svarta linjer och dessa representerar skärningen mellan modellerna.
  • Man kan skapa en Schakt- och fyllplan, den sparas i Autocad format.
  • Man kan också skapa nivåkurvor med väldigt hög ekvidistans, då får man bara linjen som visar skärningen mellan modellerna(nollan).
Volymberäkning MBS

– Varför blir det frågetecken i volymrapporten och hur blir man av med dem?

Frågetecken uppstår i volymrapporten om en eller flera sektioner inte kan beräknas. Detta kan bl.a. bero på ett fel i normalsektionen eller för små modeller, som kan resultera i att det inte går att få slutna ytor. Blir det frågetecken någonstans i rapporten kommer även slutsummeringen att skrivas så. Anledningen till det är att man inte av misstag ska använda en volymberäkning som innehåller fel.

Ritningar/Rapporter

– Hur ändrar jag logotyp i en stämpel?

Det enklaste är att i Geo öppna en befintlig stämpel, som innehåller en bild. Välj Öppna, ändra filformat till Ritningar (*.dra, *.sot) och välj aktuell .sot-fil i globalkatlogen.

plotpanelchange2

I trädvyn till vänster finns en rad som heter DrawImage (eller DrawEnhMetaFile)… högerklicka över den och välj egenskaper. Där finns nu möjligheten att lägga in sin egen bild.

– Hur kan jag ändra logotyp i sidhuvudet på en rapport (*.rep) vid utskrift?

Genom att gå in under Redigera/Inställningar och fliken Utskrift är det möjligt att byta från standardbilden Geoblue till en valfri. Notera dock att bildfilen måste finnas i globalkatalogen annars hittar inte Geo den.

– Finns det något smidigt sätt att dela med sig av rapporter till någon som inte har Geo?

Om man väljer att spara en rapport kan det göras i vårt eget format .rep eller i MS Excel 97-format. Det går även att spara en numerisk vy i Excel-format under Vyer/Spara vy som.

Hur kan man leverera inmätningar i standarden BH90.

Vi har kompletterat vår kodlista med ett fält för ”Element” som vi döpt till BH90, där vi översätter gamla lagernamnet. Man mäter och kodar med tre, fyr eller 6 -ställiga ”Fält nr.” eller ”Kod” som punktkoder. Kodlista sbg2_BH90.cod är anpassad så att den stämmer överens med ”Kodlista BH90 för Landskapsinformation” i ”Bygghandling 90 Utgåva 2”. Det finns inget stöd för BSAB. Man kan även använda sig av fältet ”Status” enligt BH90.

Projektet ska ha följande kodlista inställt: ”sbg2_BH90.cod”. Lämpligt är att symbolfil ”sbg2.sym” och linjetypsfil ”sbg2.glt” är inställda

Export till Autocad DWG görs via ”Vyer > Spara vy som… > Autocad-fil”. Välj ”Grundritningsmall (*.dwt) som innehåller lager för linjer och block för symboler enligt kodlistan. De mallar som finns med i Geo Professional stöder ”Vägverkets Rithandbok för Mät och kartering”. Mallarna har namnen ”sbg2_nnnn.dwt”, där ”nnnn” står för den skala symboler använder sig av. Tänder man upp attribut i Geo-format sätter man samma skala längre ner i dialogen. Vidare i nästa dialog så bocka man för att man vill använda lageröverföringen ”Konvertering till standarden BH90” och där kan man även ställa in fältet ”Part”

Vid konverteringen så skickas information ut till in- och utmatningsfönstret och man kan se om det blir några fel i konverteringen. Fel som kan uppkomma är

  • Glömt kod för punkter
  • Första punktkoden i linjer definiera hela linjen, linjekoder används ej
  • Linjer kan i BH90 vara definierade som symboler och punkter kan vara definierade som linjer, detta kan man kontrollera i kodlistan
  • Gamla punktkoder kan finnas som ej har definition i BH90, man kan definiera detta själv i kodlistan
  • Man kan även definiera och använda egna mallar, men man måste då fylla i egen information om blocknamn, lager och elementnamn för punktkoden.
Hur tänder jag punktinformation för linjepunkter?

Genom att gå in under Vyer/Dokumentegenskaper och bocka i rutan ”Använd för punkter i linjer”.punktinfo1

Varför syns inte markeringarna (greppen) på en linje eller en punkt när man pekar på dem?

Den mest troliga förklaringen är att objektet inte tillhör den aktiva filen. Det är endast den aktiva filen som det går att arbeta med. Dock går det att hämta information från ej aktiva filer, kopiera, göra inpassningar mm.

Det kan också vara så att fel snappverktyg är valt eller att färgen på greppen är den samma som bakgrundsfärgen, se Vyer/Inställningar.

3D-vy

– Om jag vill spara en 3d-vy hur gör jag då?

När 3D-vyn visas går den att spara som bitmap-bild. Gå in under Vyer/Spara vy som och välj Bitmap.

– 3D-vy ser konstig ut

3dvy_1

Detta kan bero på att man kör med felaktigt, för dåligt grafikkort eller drivrutiner för grafikkortet inte är uppdaterade. Använder man NVIDIA så har de en meny för 3D-inställningar, där finns Programinställningar > Lägg till Geo.exe och att programmet ska använda högpresterande grafikkort. Starta om Geo

Vad är LandXML?

LandXML är ett dataformat avsett för utbyte av data mellan olika program.

Det kan innehålla till exempel terrängmodeller, linjer och profiler, koordinater och mycket annat.

Användningsområdet är bland annat att utbyta massbeskrivningar med program som ViaNovas NovaPoint, Bentleys InRoad och InRail, samt Leicas GPS/TPS 1200.

Hur gör jag en egen kodlista till Leica 1200-systemet?

Antingen så använder man sig av Leica GeoOffice, där det finns verktyg för att skapa kodlistor, eller så editerar man de filer som skapats från SBG.cod och SBG2.cod, så de passar ens eget behov.

När jag ska koordinatberäkna är stationer och/eller bakobjekt röda, vad är det för fel?

Om stationer/bakobjekt är röda vid koordinatberäkning betyder det att det saknas kända koordinater för objekten. Kontrollera att rätt fil är angiven som fil med kända punkter under projektinställningarna och att sökta punkter existerar i filen. Har man gått ett polygontåg så krävs rätt kod, PP eller PI, för att Geo ska använda koordinaterna successivt i beräkningen.

Varför får jag ingen snappindikering vid vissa funktioner trots att lämplig snapp är vald?

Många av funktionerna där ett objekt ska väljas har s.k. inbyggd snapp. I dessa lägen är snappmarkeringen borttagen. Om markören ändras från hårkors till en ”pick-box” (markeringsbox) när funktionen väljs behövs ingen snapp. I detta fallet kan det vara bra att ha ”objektidentifiering” (gul ettikett) påslagen, så man ser vad geo hittar under markeringsboxen.

Hur får jag fram den lutande arean i en terrängmodell?

Antingen tas modellinformationen fram, Data/Modellinformation eller så används Modell mot modell och som yta efter bearbetning väljs en referensnivå.

Hjälppunktsfilen – project.gft – går inte att öppna eller så ser menyerna konstiga ut.

Om hjälppunktsfilen skadas kan det leda till att den inte går att öppna eller så ser ikonerna och rullningslisten för aktiv fil konstiga ut. För att rätta till detta är det bara att radera filen project.gft. Geo skapar automatiskt en ny om den saknas när hjälplagret ska tändas.

Jag upplever Geo som segt när jag använder funktionen Bind ihop linjer.

Detta kan bero på om man ha licens mot licensserver, utan hårdvarulås. Vi har optimerat detta ifrån version 2015.2.943 av Geo Professional. Prova att uppdatera om du upplever dessa problem

När jag arbetar i en terrängmodell så syns inte hela höjden på statusraden.

Detta kan bero på att skärminställningar för visning och upplösning inte matchar varandra. Har använt Win10 för menybilder, men det borde vara liknande benämningar i Win7 och Win8 annars kan man fråga sin IT-avd. Nedan följer en guide vad som ska kontrolleras.

Kontrollera att lägst version Geo Professional version 2016.2.960 används

Högerklicka på skrivbordet

DesktopRightClick

Välj Bildskärmsinställningar

Bildskärmsinställningar 100_150

  1. Här är menyvalet för inställningarna som berörs.
  2. Här hanteras förstoringsgraderna 100% till 150%, se till att du har ställt in inom detta intervallet. Skärmarna hanteras individuellt.
  3. Tryck ”Avancerade skärminställningar” för att kolla ”Upplösningen” för dina skärmar.

Avancerade skärminställningar

Markera dina skärmar i rutan ovanför och kontrollera att den ”(rekommenderade)” upplösningen används. Eventuellt måste man Logga ut från Windows för att denna inställning ska sparas och användas.

Tunnel TBS

– Beräkningar med Punktmoln

Om man inte får ut beräkningar med hela tunneln kan det bero på att man satt begränsningar under Data > Punktmoln tvärsektioner > Korridor > Väster och höger sidomått. T.ex man får inte hela tunneln när man räknar Data > ”Jämför mätt mot teoretiskt”

Färgschema för tunnel och differensmodeller

Länk till några färdiga scheman hämtar man här

För att lägga in dessa får man packa upp och dubbelklicka på registerfilerna. Då lägger schemana sig rätt för användning. Tänk på att man generellt behöver vara administratör för att köra sådana här registerfiler

Skapa en koordinatlinje av en väglinje.

Öppna din väglinje. Öppna även en tom koordinatfil i samma fönster och ha den aktiv. Använd nu ikonen ”Kopiera linje till aktivt dokument”, funktionen finns även under Verktyg > Kopiera till aktivt dokument > Linje. Kontrollera överensstämmelse i 3D

Täta upp alla koordinatlinjer med ett avstånd.

Om man av nån anledning vill infoga fler punkter på många linjer i en koordinatfil, kan man utnyttja terrängmodellsskapandet, där det finns en funktion för att ange ett avstånd för att dela upp alla linjer i mindre delar. Inställningen heter ”Delning av brytlinjer i mindre delar”. Ange avståndet mellan punkter man vill använda. Skapa modellen. Använd sedan funktionen ”Spara linjer och punkter” under Data för att skapa tillbaka din koordinatfil.

Kan man konvertera sina punktkoder i en koordinatfil till den beskrivning som finns i kodlistan

Ja man kan konvertera detta. Vi har en funktion under Funktioner > Översätt koder…
Här väljer man in en kommaseparerad txt-fil. Den ser ut som följer:

100,Pkt
200,Sten

Med detta data kan man översätta punktkod fram och tillbaka.

Vi har gjort en färdig kommaseparerad txt-fil för vår kodlista sbg2_BH90 som man kan använda för att översätta koder till beskrivning. Du kan ladda ner den här

(Vissa webläsare öppna filen och då får man högerklicka på länken och klicka på ”Spara länk som…”)